# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?<=^|\v)
\h*+\*\h*+
(?:
(?:
(?P<annotation>
@(?P<name>\w++)
(?:
(?<=@param)\h++(?P<type>\w++(?:\[\])?)\h++\$(?P<variable>\w++)
|(?<=@return)\h++(?P<type>\w++(?:\[\])?)
|(?<=@throws)\h++(?P<class>\w++)
|(?<=@cache)\h++(?P<time>\d++)
|(?<=@roles)\h++(?P<roles>\w++(?:\h*+,\h*+\w++)*)
)?
)
)
(?P<comment>\h++[^\v]++)?
(?:(?P<comment>\v)\h*+\*\h*+(?P<comment>[^\v@\h\*][^\v]++))*+
|(?P<description>(?:[^\v@\h\*][^\v]++)
(?:
\v\h*+\*\h*+[^\v@\h\*][^\v]++
)*+
)
)
"""
test_str = ("/**\n"
" * bla bla \n"
" *bla2 @ bla2 @\n"
" *\n"
" * bla bla 3\n"
" *\n"
" * @olivier voila\n"
" * @param string $sku1 bidule\n"
" *\n"
" * @param string[] $sku2\n"
" *\n"
" * @param string $sku3 toto bidule @\n"
" * machin truc\n"
" *\n"
" * @param string $sku4\n"
" * machin truc\n"
" *\n"
" * @deprecated\n"
" *\n"
" * @deprecated toto\n"
" *\n"
" * @throws Exception\n"
" * @throws Exception\n"
" * machin\n"
" * @return Cfe_Type_Product\n"
" * @cache 3600\n"
" * @roles toto, titi,truc , machin\n"
" */")
matches = re.finditer(regex, test_str, re.VERBOSE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.