use strict;
my $str = 'Server3.lands.resnet.qg
server2.dpi.qld.gov.au
Server3201.org.local';
my $regex = qr/(?<ServerName>[^.][a-z 0-9 A-Z _ -]*)\.(?<Domain>.*)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}