$re = '/(?<ServerName>[^.][a-z 0-9 A-Z _ -]*)\.(?<Domain>.*)/';
$str = 'Server3.lands.resnet.qg
server2.dpi.qld.gov.au
Server3201.org.local';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);