// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?<ServerName>[^.][a-z 0-9 A-Z _ -]*)\.(?<Domain>.*)").unwrap();
let string = "Server3.lands.resnet.qg
server2.dpi.qld.gov.au
Server3201.org.local";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}