import Foundation
let pattern = #"(?<ServerName>[^.][a-z 0-9 A-Z _ -]*)\.(?<Domain>.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Server3.lands.resnet.qg
server2.dpi.qld.gov.au
Server3201.org.local
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}