import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "RDATE(?:(?:;(?<value_param>VALUE=(?<value_param_type>DATE-TIME|DATE|PERIOD)))|;(?<tzid_param>TZID=(?<tzid_param_tz>[\\w\\/-]+))|;(?:(?!VALUE|TZID)\\w+=[a-zA-Z0-9_\\-\\/]+))+:(?<value>(?:.*))";
final String string = "RDATE;FAKE=fake;VALUE=DATE-TIME;TZID=America/New_York:19970714T083000";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}