use strict;
my $str = 'RDATE;FAKE=fake;VALUE=DATE-TIME;TZID=America/New_York:19970714T083000';
my $regex = qr/RDATE(?:(?:;(?<value_param>VALUE=(?<value_param_type>DATE-TIME|DATE|PERIOD)))|;(?<tzid_param>TZID=(?<tzid_param_tz>[\w\/-]+))|;(?:(?!VALUE|TZID)\w+=[a-zA-Z0-9_\-\/]+))+:(?<value>(?:.*))/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}