re = /RDATE(?:(?:;(?<value_param>VALUE=(?<value_param_type>DATE-TIME|DATE|PERIOD)))|;(?<tzid_param>TZID=(?<tzid_param_tz>[\w\/-]+))|;(?:(?!VALUE|TZID)\w+=[a-zA-Z0-9_\-\/]+))+:(?<value>(?:.*))/
str = 'RDATE;FAKE=fake;VALUE=DATE-TIME;TZID=America/New_York:19970714T083000'
# Print the match result
str.match(re) do |match|
puts match.to_s
end