package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:https?:\/\/)?(?:www\.)?(?:youtu\.be\/|youtube\.com\/(?:embed\/|v\/|watch\?v=|watch\?.+&v=))((\w|-){11})(?:\S+)?$`)
var str = `kolla in den här!! https://www.youtube.com/watch?v=eX2qFMC8cFo`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}