const regex = /^([^"\'\/]*)[^"\']*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^"\\\'\\\/]*)[^"\\\']*', 'g')
const str = `steve=
"john"
'leo'
sophie
"john
eliott"
'john
john'
`;
const subst = `<span class="">\0</span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);