// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"^([^"\'\/]*)[^"\']*"#).unwrap();
let string = "steve=
\"john\"
'leo'
sophie
\"john
eliott\"
'john
john'
";
let substitution = "<span class=\"\">\\0</span>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}