$re = '/(\b(\w*?)([cf])(\w*))\b(?=[\s\S]*(\b\2(?!\3)[cf]\4))/';
$str = 'came
cat
can
cans
fame
fast
fan
fans
rice
rife
cat
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);