#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\b[A-Za-zÀ-ÖØ-öø-ÿ]+)\.?\-?[A-Za-zÀ-ÖØ-öø-ÿ]+"
Local $sString = "fiji" & @CRLF & _
"new-caledonia " & @CRLF & _
"saint-lucia " & @CRLF & _
"st.-vincent-grenadines " & @CRLF & _
"curaçao " & @CRLF & _
"saint-kitts-and-nevis " & @CRLF & _
"falkland-islands"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")