#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\babcdef)(?:.*\n)*(?:\bfedcba)"
Local $sString = "patata" & @CRLF & _
"abcdef" & @CRLF & _
"Aliquam erat volutpat. Proin ultrices" & @CRLF & _
"Testing" & @CRLF & _
"" & @CRLF & _
"test[](test)" & @CRLF & _
"Testing" & @CRLF & _
"fedcba" & @CRLF & _
"Testing" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")