re = /(?:\babcdef)(?:.*\n)*(?:\bfedcba)/m
str = 'patata
abcdef
Aliquam erat volutpat. Proin ultrices
Testing
test[](test)
Testing
fedcba
Testing
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end