#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?!.*?\{{2}\h*translateAttr).*(*SKIP)(*F)|=(["'])((?:\\\1|(?!\1).)*)\1"
Local $sString = "<body>" & @CRLF & _
" {{ t "foo" }}" & @CRLF & _
" {{t "bar"}}" & @CRLF & _
" {{t 'baz'}}" & @CRLF & _
" {{ t 'qux' }}" & @CRLF & _
" {{ t "bux {{ var }}" var="foo" }}" & @CRLF & _
" {{ button titleTranslation="button.add_user.title.foo" }}" & @CRLF & _
" {{ button labelTranslation = 'button.add_user.title.bar' }}" & @CRLF & _
" {{ translateAttr title="button. ' add_user.title" data-disable-with='button.add_user.disabled' }}" & @CRLF & _
" {{translateAttr title="button.! add_user \"quote\" title" data-disable-with='button.add_user.disabled'}}" & @CRLF & _
"</body>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")