re = /(?:[0-9]+ )?\(*([a-z]+[₀-₉]*)+\)*[₀-₉]*/i
str = '2 HCl + 12 Na + 3 (Na₃Cl₂)₂₄ → 2 NaCl + H₂'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end