$re = '/(?:[0-9]+ )?(?:(?:[a-z]+[₀-₉]*)+|\((?:[a-z]+[₀-₉]*)+\))[₀-₉]*/i';
$str = '2 HCl + 12 Na + 3 (Na₃Cl₂)₂₄ → 2 NaCl + H₂';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);