using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^']*(?=lamb)[^']*)";
string input = @"'Baa, baa, black sheep, have you any wool?
Yes sir, yes sir, three bags full!
One for the master
One for the dame'
'Mary had a little lamb,
its fleece was white as snow;
And everywhere that Mary went,
the lamb was sure to go.'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}