$re = '/^0(?:\R(?!\R)|.)*?\b(?:kryptonite|stalagmite)\b/m';
$str = '00:20314 lorem ipsum
want this
kryptonite
00:02314 quux
padding
dont want this
00:03124 foo
neither this
00:01324 foo
but we want this
stalagmite
00:02134 tralala
not this
00:03124 bar foo
and we want this
kryptonite but not this(!)
00:02134 foo bar
and not this either
00:01234 dolor sit amet
EOF';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);