$re = '/\b(?![a-z]*([a-z])([a-z])\2\1[a-z]*\b)[a-z]+\b/i';
$str = 'This is a regex that matches everything i want to exclude, which is words like abba, trillion ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);