const regex = /(?!<\S)(?!\S{11})(?!\S*berry\S)(\S+berry)(?!$)/im;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!<\\S)(?!\\S{11})(?!\\S*berry\\S)(\\S+berry)(?!$)', 'im')
const str = `Some æøåberry please - Mmmm, not Blueberyflavouredblackberry
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}