// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)color+=([\#]{1}|[\w\W]{1}|[\#A-Za-z0-9]{7,})").unwrap();
let string = "test[color=#663300]test[/color]vdfvd
test[color=#663300]test[/color]vdfvd
[color=#]test[/color]
[color=#]test[/color]
test
[color=#66330gdgf0]test[/color]
[color=#66330gdgf0]test[/color]
test
[color=]test[/color]
[color=]test[/color]
test
test
test";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}