const regex = /^(?:2018|201[0-7]|200[0-9]|1[0-9]{1,3}|[0-9]{1,3})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:2018|201[0-7]|200[0-9]|1[0-9]{1,3}|[0-9]{1,3})$', 'gm')
const str = `0
1
2
9
10
40
100
101
229
400
777
888
999
1000
1001
1799
1800
1900
2001
2016
2018
2019
2020
3000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}