const regex = /(?m)^[^\S\r\n]*(\S+)[ \t]+(\S+)[ \t]+(\S+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m)^[^\\S\\r\\n]*(\\S+)[ \\t]+(\\S+)[ \\t]+(\\S+)', 'g')
const str = ` FOO 100 BOR
PAL 350 PIL
KIL 090 KUP`;
const subst = `array($2, "$1", "$3"),`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);