using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:[a-z0-9_-]+|[a-z0-9_-]+\*|\*)\/)*([a-z0-9_-]+|[a-z0-9_-]+\*|\*|>)$";
string input = @"my/simple/topic/123
my/simple/topic/123/>
my/simple/topic/123/*
my/simple/to*/123/*
my/simple/topic/*/*/>
*/simple/topic/>
my
*
>
my/*imple/topic
my/simple/topic/
my/simple/topic/>/123
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}