const regex = new RegExp('^(?:(?:[a-z0-9_-]+|[a-z0-9_-]+\\*|\\*)\\/)*([a-z0-9_-]+|[a-z0-9_-]+\\*|\\*|>)$', 'mg')
const str = `my/simple/topic/123
my/simple/topic/123/>
my/simple/topic/123/*
my/simple/to*/123/*
my/simple/topic/*/*/>
*/simple/topic/>
my
*
>
my/*imple/topic
my/simple/topic/
my/simple/topic/>/123
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}