import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\w+;)?\\s*public\\s+\\w+\\s+methodName\\s*\\(\\)\\s*$";
final String string = "Someword; public void methodName()\n"
+ "public void methodName()\n\n"
+ "Someword; public void; methodName();\n"
+ "public void methodName();";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}