$re = '/^(?:\w+;)?\s*public\s+\w+\s+methodName\s*\(\)\s*$/m';
$str = 'Someword; public void methodName()
public void methodName()
Someword; public void; methodName();
public void methodName();';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);