use strict;
my $str = 'Field Name* * ';
my $regex = qr/(.*)\*/mp;
my $subst = '$1mandatory';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";