using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/*(?<!\\)[^\/]*\/*(?<!\\)[^\/]*";
string input = @"/10/102-\/ABC083.013/11/201201/20/83/30/463098194/32/7.7/40/0:20";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}