const regex = /\/*(?<!\\)[^\/]*\/*(?<!\\)[^\/]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/*(?<!\\\\)[^\\\/]*\\\/*(?<!\\\\)[^\\\/]*', 'gm')
const str = `/10/102-\\/ABC083.013/11/201201/20/83/30/463098194/32/7.7/40/0:20`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}