$re = '/\/*(?<!\\\\)[^\/]*\/*(?<!\\\\)[^\/]*/m';
$str = '/10/102-\\/ABC083.013/11/201201/20/83/30/463098194/32/7.7/40/0:20';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);