# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?=(?:[^a-zA-Z\n]*[a-zA-Z]){4}[^a-zA-Z\n]*$)(?=(?:[^\d\n]*\d){3}[^\d\n]*$)"
test_str = ("t1E2S3T\n"
"t1E2S33")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.