using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*\b(\d+)\b.*\b\1\b)\d+(?:,\d+)*$";
string input = @"123
123,1234
1,2,45,4567
12,2343,12
,123,3444
,3344
12,3,,344
23,";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}