use strict;
my $str = '123
123,1234
1,2,45,4567
12,2343,12
,123,3444
,3344
12,3,,344
23,';
my $regex = qr/^(?!.*\b(\d+)\b.*\b\1\b)\d+(?:,\d+)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}