#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!\s|digit-)([0-9]{4})(?=-digit|\.|\?|\s)"
Local $sString = " 3400-digit" & @CRLF & _
" 5000 5000 " & @CRLF & _
" 6700?" & @CRLF & _
"digit-9134?" & @CRLF & _
" 7500." & @CRLF & _
"" & @CRLF & _
"$5000 " & @CRLF & _
"£5550 " & @CRLF & _
"#5550 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")