using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!\s|digit-)([0-9]{4})(?=-digit|\.|\?|\s)";
string input = @" 3400-digit
5000 5000
6700?
digit-9134?
7500.
$5000
£5550
#5550 ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}