use strict;
my $str = ' 3400-digit
5000 5000
6700?
digit-9134?
7500.
$5000
£5550
#5550 ';
my $regex = qr/(?!\s|digit-)([0-9]{4})(?=-digit|\.|\?|\s)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}