const regex = new RegExp('(?i)(^|/)thumbs\\.db$', 'gm')
const str = `thumbs.db
a/thumbs.db
a/b/thumbs.db
a/b/thumbs.dblala
a/b/thumbs.db.lala`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}