// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)CustRS|Customer Requirements|Customer Specification|02 - Regulatory|\*\\remote|").unwrap();
let string = "CustRS/
CustRS/remote
CustRS/Customer Requirements
CustRS/02 - Regulatory
CustRS/10 - remote
CustRS/Product_remote
CustRS/Customer Requirements/remote
CustRS/Product_remote/remote";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}