const regex = /^(19\d{2}|2\d{3})-((0[13578]|1[02])-([0-2]\d|3[01])|02-[0-2]\d|(0[469]|11)-([0-2]\d|30))T([01]\d|2[0-4])(:[0-5]\d){2}(\.\d{3})?(Z|([+-]([01]\d|2[0-3]):[0-5]\d))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(19\\d{2}|2\\d{3})-((0[13578]|1[02])-([0-2]\\d|3[01])|02-[0-2]\\d|(0[469]|11)-([0-2]\\d|30))T([01]\\d|2[0-4])(:[0-5]\\d){2}(\\.\\d{3})?(Z|([+-]([01]\\d|2[0-3]):[0-5]\\d))$', 'gm')
const str = `2999-12-31T23:59:59.999+23:59
1900-01-01T00:00:00.000-23:59`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}