$re = '/\[(\[?)(embed|wp_caption|caption|gallery|playlist|audio|video|code_snippet|democracy|democracy_archives|download)(?![\w-])([^\]\/]*(?:\/(?!\])[^\]\/]*)*?)(?:(\/)\]|\](?:([^\[]*+(?:\[(?!\/\2\])[^\[]*+)*+)\[\/\2\])?)(\]?)/m';
$str = '[caption id="attachment_33674" align="aligncenter" width="900"]<a href="http://barnaul.press/wp-content/uploads/2021/02/IMG_9329.jpg"><img class="size-full wp-image-33674" src="http://barnaul.press/wp-content/uploads/2021/02/IMG_9329.jpg" alt="" width="900" height="600" /></a> В составе "Снежного десанта" участвовали два отряда ветеранов движения из числа бывших студентов.<br />Фото Михаила Полубедова[/caption]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);