package main
import (
    "regexp"
    "fmt"
)
func main() {
    var re = regexp.MustCompile(`(.*)p\.PERSONAL=[^&]*(.*)`)
    var str = `zeit.BUCHUNGSTAG=[2017-11-01T00%3A00%3A00;2018-02-01T23%3A59%3A59]&_viewjoins=zeit|ba|ma|p&p.PERSONAL=in[deil_felix;lechner_carina]&fdf=dfuebfek
p.PERSONAL=in[deil_felix;lechner_carina]&zeit.BUCHUNGSTAG=[2017-11-01T00%3A00%3A00;2018-02-01T23%3A59%3A59]&_viewjoins=zeit|ba|ma|p`
    
    for i, match := range re.FindAllString(str, -1) {
        fmt.Println(match, "found at index", i)
    }
}