use strict;
my $str = 'https://matrix.to/#/!PFcniQbnBEDpZRjAFF:matrix.org/$fJ3mYO2y09VdV5INemzXirpeuBLsKQGquiVA8wJIRmU?via=matrix.org&via=nexy7574.co.uk';
my $regex = qr/(http(s)?://)?matrix\.to/#/(?P<room_id>[^/]+)(/(?P<event_id>[^/?&#]+))?(?P<qs>([&?](via=[^&]+))*)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}