const regex = /((\D|^)0+(0|[1-9]+))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\D|^)0+(0|[1-9]+))', 'g')
const str = `0127.00.09.01
107.000.09.01
107.0.70.01
107.9.0.01
23.107.000.09
107.09.0.01
23.0.107.000
23.0.107.00
23.0.0127.01`;
const subst = `$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);