Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
((\D|^)0+(0|[1-9]+))
/
g
Input 1
1
New
0127.00.09.01 107.000.09.01 107.0.70.01 107.9.0.01 23.107.000.09 107.09.0.01 23.0.107.000 23.0.107.00 23.0.0127.01
Substitution
$2$3
0127.00.09.01 107.000.09.01 107.0.70.01 107.9.0.01 23.107.000.09 107.09.0.01 23.0.107.000 23.0.107.00 23.0.0127.01