$re = '/[a-c]/m';
$str = 'ab
abc
abcc
abccc
abcccc
abccccc
abcccccc
abcbcbcbc
abcbcbcbcbcbc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);