$re = '/[a-fA-F0-9]/m';
$str = 'ab
abc
abcc
abccc
abcccc
abccccc
abcccccc
abcbcbcbc
abcbcbcbcbcbc
- _ { } @ ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);