#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b\d{1,3}[.[^\S\r\n]]+\d{1,3}[.[^\S\r\n]]+\d{1,3}[.[^\S\r\n]]+\d{1,3}"
Local $sString = "127.0.0.1" & @CRLF & _
"a.b.c.d" & @CRLF & _
"127 0 0 1" & @CRLF & _
"251.147.187.212" & @CRLF & _
"174.238.178.106" & @CRLF & _
"186 40 44 191" & @CRLF & _
"127..0.0.1" & @CRLF & _
"127 0 0 1" & @CRLF & _
"127. 0 0 1" & @CRLF & _
"127. .. 0 .. . 0. . .1" & @CRLF & _
"127001" & @CRLF & _
"183.... 183.... 183.... 183d" & @CRLF & _
"127.0.0.1" & @CRLF & _
"127." & @CRLF & _
"0." & @CRLF & _
"0." & @CRLF & _
"1" & @CRLF & _
"1111.1.1.1" & @CRLF & _
"1" & @CRLF & _
"127.0.0.1 " & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")